ΣΧΕΔΙΑΣΤΕ ΜΕ ΤΟ Dia
1. ΕΙΣΑΓΩΓΗ

1.1
Τι είναι το Dia

Το Dia είναι ένα πρόγραμμα, το οποίο χρησιμοποιείται για τη σχεδίαση διαφόρων διαγραμμάτων, τεχνικών και μη. Παρέχει τη δυνατότητα στο χρήστη να επιλέξει από μία λίστα προκαθορισμένων διαγραμμάτων, τα οποία περιλαμβάνουν έτοιμα σύμβολα, σύμφωνα πάντα με τις διεθνείς προδιαγραφές. Αυτή η δυνατότητα δεν δεσμεύει τον χρήστη, ο οποίος είναι ελεύθερος να δημιουργήσει ό,τι αυτός επιθυμεί.

1.2
Περιγραφή Περιβάλλοντος Εργασίας


Το περιβάλλον εργασίας αποτελείται από το παράθυρο εργαλείων και το παράθυρο σχεδίασης του υπό κατασκευή διαγράμματός μας. Η σχεδίαση γίνεται στο παράθυρο επεξεργασίας, όπου μεταφέρουμε τα αντικείμενα που επιθυμούμε να εισάγουμε στο διάγραμμα, από το παράθυρο εργαλείων
· Το παράθυρο Εργαλείων (Diagram Editor) αποτελείται από πέντε περιοχές
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	Μπάρα Επιλογών
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	Βασικά εργαλεία κατασκευής νέων αντικειμένων
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	Αναδυόμενο Μενού επιλογής προκαθορισμένου τύπου διαγράμματος
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	Εργαλεία επιλεγμένου τύπου διαγράμματος
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	Εργαλεία διαμόρφωσης γραμμών



· Το παράθυρο Σχεδίασης (Canvas) αποτελείται : 
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	- Από το Αναδυόμενο μενού επιλογών (File, Edit,  View, Select, Objects, Tools, Dialogs, Input Methods, Help), το οποίο καθίσταται ορατό όταν πατήσουμε το βελάκι στο πάνω αριστερό άκρο του παραθύρου, και από το φύλλο σχεδίασης. 
- Από τους Χάρακες 

  (Οριζόντιος – Κατακόρυφος)
- Από το Φύλλο σχεδίασης
  (Όταν κάνουμε δεξί κλικ με το ποντίκι οπουδήποτε επάνω στο φύλλο σχεδίασης , αναδύεται το μενού επιλογών) 




2. ΤΟ ΠΑΡΑΘΥΡΟ ΣΧΕΔΙΑΣΗΣ
2.1
Γενικά

Είναι το βασικό μέρος του προγράμματος, αφού εδώ θα τοποθετηθούν και θα στοιχηθούν τα αντικείμενα που θα επιλέξει ο χρήστης για το διάγραμμά του. Όταν ένα αντικείμενο εκτυπωθεί ή αποθηκευτεί, αποθηκεύονται όλα τα περιεχόμενα του φύλλου σχεδίασης.
Έχουμε τη δυνατότητα να επιλέξουμε τη μόνιμη εμφάνιση του μενού επιλογών με τη μορφή της κλασικής μπάρας, στο επάνω μέρος του παραθύρου. Απλώς επιλέγουμε από το παράθυρο εργαλείων File → Preferences → User Interface → Use menu bar. Τότε, όμως, χάνεται η δυνατότητα ανάδυσης του μενού με δεξί κλικ στο φύλλο σχεδίασης.

2.2 Τετραγωνισμός

Οι γραμμές τετραγωνισμού είναι αντίστοιχες με αυτές που υπάρχουν στις κόλλες καρέ (με τετραγωνάκια) και δεν εκτυπώνονται. Βοηθούν το χρήστη να στοιχίζει εύκολα τα αντικείμενα στο φύλλο σχεδίασης. Οι ιδιότητες του τετραγωνισμού εμφανίζονται στην επιλογή : View → Diagram Properties. Εκεί ο χρήστης έχει τη δυνατότητα να μορφοποιήσει τον τετραγωνισμό όπως αυτός θέλει από απόψεως διαστάσεων, σχήματος ή χρώματος, ενώ με την επιλογή View → Show Grid τον καθιστά ορατό ή όχι. 
2.3 Χάρακες

Οι χάρακες βρίσκονται στο επάνω και στο αριστερό μέρος του φύλλου σχεδίασης και δείχνουν σε εκατοστά τις αποστάσεις. Σε κάθε χάρακα υπάρχει ένας δείκτης, ο οποίος ακλουθεί τον κέρσορα του ποντικιού. Το αν θα είναι οι χάρακες ορατοί ή όχι ρυθμίζεται από την επιλογή View → Show Ruler.
2.4 Λοιπά χαρακτηριστικά
Το χρώμα του φόντου μεταβάλλεται από την επιλογή View → Diagram Properties → Colors. Αν το επιλεγμένο χρώμα είναι σκούρο, τότε αυτόματα ο τετραγωνισμός θα χρωματιστεί λευκός, ώστε να είναι ορατός.
Στο κάτω μέρος του παραθύρου σχεδίασης υπάρχει η επιλογή μεγέθυνσης του σχεδίου (Zoom). Το φύλλο σχεδίασης μπορεί να μεγεθυνθεί έως και 400 %, βοηθώντας το χρήστη στην ακριβέστερη σχεδίαση λεπτομερειών. 
Επίσης, δίπλα ακριβώς από την επιλογή του Zoom, υπάρχει η επιλογή Snap To Grid. Εάν την επιλέξουμε, τότε όλα τα σχήματα που θα εισάγονται στο φύλλο σχεδίασης, θα τοποθετούνται αυτόματα, έτσι να «πατάνε» στις γραμμές και τις γωνίες του τετραγωνισμού.    

3. ΤΑ ΑΝΤΙΚΕΙΜΕΝΑ
3.1 Γενικά

Αντικείμενα είναι όλα τα σχήματα που αποτελούν το διάγραμμα. Το Dia προσφέρει δύο τύπους αντικειμένων :

· Προκαθορισμένα : Δεν επιδέχονται επεξεργασίας, παρά μόνο μεταβολή μεγέθους και τροποποίηση των ήδη υπαρχουσών ιδιοτήτων. 
· Ορισμένα από το χρήστη : Κατασκευάζονται με σύνθεση των βασικών σχημάτων του παραθύρου εργαλείων.
Για να τοποθετήσουμε ένα έτοιμο αντικείμενο επί του φύλλου σχεδιάσεως, επιλέγουμε το επιθυμητό αντικείμενο στο παράθυρο εργαλείων, με το ποντίκι και κατόπιν κάνουμε κλικ με το ποντίκι στο σημείο του φύλλου όπου θέλουμε να το τοποθετήσουμε. Τοποθέτηση αντικειμένου γίνεται και σύροντας το ποντίκι (Drag And Drop). Το νέο αντικείμενο εμφανίζεται πλαισιωμένο με μικρά πράσινα κουτάκια που καθορίζουν τα όριά του.

3.2 Ενέργειες επί Αντικειμένων

· Μετακίνηση : Κρατώντας πατημένο το αριστερό πλήκτρο του ποντικιού εντός, της ορισμένης από τα πράσινα κουτάκια, περιοχής του αντικειμένου, μετακινώντας τον κέρσορα, μετακινείται και το αντικείμενό μας.
· Καθορισμός Μεγέθους : Έλκοντας κάποιο από τα πράσινα κουτάκια του πλαισίου του αντικειμένου, μεταβάλλεται η αντίστοιχη διάστασή του.
· Διαγραφή : Επιλέγουμε το αντικείμενο με το ποντίκι και πατάμε Edit → Delete
3.3 Γραμμές

· Στο κάτω μέρος του παραθύρου εργαλείων βρίσκονται τρία κουμπιά. Το μεσαίο είναι για επιλογή του τύπου της γραμμής, το αριστερό για την επιλογή του σχεδίου της αρχής της γραμμής (π.χ. ουρά βέλους) και το δεξί για την επιλογή του σχεδίου της κατάληξης της γραμμής (π.χ. μύτη βέλους). Επίσης, πάνω από το μεσαίο κουμπί, υπάρχει επιλογή χρώματος της γραμμής και η επιλογή πάχους γραμμής.
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· Κάνοντας διπλό κλικ επάνω σε ένα αντικείμενο, τοποθετημένο στο φύλλο σχεδίασης, ανοίγει ένα παράθυρο επιλογών, από όπου μπορούμε να τροποποιήσουμε τα χαρακτηριστικά του.

Όλα τα παραπάνω ισχύουν μόνο για τα βασικά σχήματα. Τα προκαθορισμένα, επειδή βασίζονται σε διεθνείς προδιαγραφές, έχουν ειδικό παράθυρο επιλογών για τέτοιου είδους τροποποιήσεις, μέσα στα επιτρεπόμενα πλαίσια. 
4. ΒΑΣΙΚΑ ΑΝΤΙΚΕΙΜΕΝΑ

1. Text : Επιτρέπει την εισαγωγή κειμένου 

Προσφερόμενες επιλογές : Είδος / Μέγεθος / Χρώμα γραμματοσειράς και Στοίχιση.
2. Box : Δημιουργία παραλληλογράμμου. 

Προσφερόμενες επιλογές : Μορφοποίηση γραμμών πλαισίου, Φόντο, Εξομάλυνση γωνιών.
3. Elipse : Δημιουργία έλλειψης

Προσφερόμενες επιλογές : Μορφοποίηση γραμμών πλαισίου, Φόντο.
4. Polygon : Δημιουργία πολυγώνου. Βοηθάει στην κατασκευή σχημάτων με ευθείες.

Προσφερόμενες επιλογές : Μορφοποίηση γραμμών πλαισίου, Φόντο, Προσθήκη γωνίας

5. Beziergon : Δημιουργία πολυμορφικού σχήματος (σαν το πολύγωνο, αλλά με καμπύλες) και δυνατότητα περιστροφής.
Προσφερόμενες επιλογές : Μορφοποίηση γραμμών πλαισίου, Φόντο, Προσθήκη ακμής

6. Line : Κλασική γραμμή 
7. Arc : Δημιουργία γραμμής σε σχήμα τόξου κύκλου

8. Zigzag Line : Δημιουργία γραμμής με γωνίες 90ο 

9. Poly Line : Δημιουργία γραμμής με γωνίες οποιουδήποτε μεγέθους

10. Bezier Line : Δημιουργία γραμμής με καμπύλες και δυνατότητα περιστροφής
Για τα αντικείμενα 6 – 11, ισχύουν οι ιδιότητες των γραμμών που αναλύθηκαν στην παράγραφο 3.2

11. Images : Χρησιμοποιείται για εισαγωγή έτοιμης εικόνας, από αρχείο. Με το που τοποθετηθεί στο φύλλο σχεδίασης, εμφανίζεται εντός του πλαισίου ένα εικονίδιο που γράφει “Broken Image”. Για να εισάγουμε μια εικόνα επιλέγουμε Object → Properties → Browse και επιλέγουμε το κατάλληλο αρχείο.
Προσφέρεται επίσης η δυνατότητα εισαγωγής πλαισίου γύρω από την εικόνα.

5. ΠΡΟΚΑΘΟΡΙΣΜΕΝΑ ΑΝΤΙΚΕΙΜΕΝΑ


Τα προκαθορισμένα αντικείμενα περιλαμβάνουν σχήματα, βασισμένα στις αντίστοιχες διεθνείς προδιαγραφές, για σχεδίαση των παρακάτω :  

1. Ηλεκτρικά – Ηλεκτρονικά Κυκλώματα
2. Δίκτυα
3. UML Διαγράμματα
4. Διαγράμματα Ροής
5. Χάρτες
6. Υδραυλικά Συστήματα
7. Συστήματα Χημικής Μηχανικής
8. Χρονοδιαγράμματα
9. Διαγράμματα CISCO
6. ΤΟ ΜΕΝΟΥ OBJECTS

Υπάρχουν κάποιες επιλογές που αφορούν στα αντικείμενα που τοποθετούνται στο φύλλο σχεδίασης και εμφανίζονται με την επιλογή Oblects από το αναδυόμενο μενού :

· Send to Back / Front : Τοποθετεί το αντικείμενο πίσω / μπροστά από όλα τα υπόλοιπα  
· Send Backwards / Forwards : Τοποθετεί το αντικείμενο μόνο μία θέση πίσω / μπροστά
· Group / Ungroup : Ομαδοποίηση / Διάλυση Ομάδας αντικειμένων
· Align : Προσφέρει διάφορες επιλογές στοίχισης των αντικειμένων 
7. ΕΠΙΛΟΓΗ ΑΝΤΙΚΕΙΜΕΝΩΝ


Η πιο συνηθισμένη ενέργεια, κατά τη διάρκεια μιας εφαρμογής μας στο Dia, είναι η επιλογή των επιθυμητών αντικειμένων. Από τη στιγμή που θα τοποθετηθεί το πρώτο σχήμα στο φύλλο σχεδίασης έως και την ολοκλήρωση του διαγράμματος, επιλέγουμε αντικείμενα είτε για να τα προσθέσουμε είτε για να αλλάξουμε τη θέση και τις ιδιότητές τους. Άλλωστε, βασική προϋπόθεση για την δυνατότητα επεξεργασίας ενός αντικειμένου είναι να είναι επιλεγμένο.

7.1 Απλή Επιλογή
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	Η επιλογή ενός αντικειμένου γίνεται με ένα απλό κλικ του ποντικιού επάνω του. Όταν το αντικείμενο είναι επιλεγμένο εμφανίζονται πράσινα κουτάκια στις γωνίες και τις πλευρές του. Τότε το αντικείμενο είναι διαθέσιμο για οποιαδήποτε επεξεργασία (μεγέθους, χρώματος κλπ). Για να απελευθερώσουμε το αντικείμενο, αρκεί να κάνουμε κλικ με το ποντίκι σε οποιαδήποτε ελεύθερη περιοχή του φύλλου σχεδίασης. 




7.2
Πολλαπλή Επιλογή
Ο πιο απλός τρόπος για να επιλέξουμε περισσότερα του ενός αντικείμενα, είναι να κάνουμε κλικ σε μία ελεύθερη περιοχή του φύλλου σχεδίασης και να σύρουμε τον κέρσορα, με πατημένο το αριστερό πλήκτρο του ποντικιού, ώστε να δημιουργηθεί ένα παραλληλόγραμμο πλαίσιο. Όσα αντικείμενα βρίσκονται εντός του πλαισίου θα επιλεχθούν.

Άλλος τρόπος είναι να κρατήσουμε πατημένο το πλήκτρο Shift και να επιλέγουμε ένα ένα τα αντικείμενα που μας ενδιαφέρουν.
Μόλις ολοκληρώσουμε την επιλογή μας, τα πράσινα κουτάκια της περιμέτρου θα εμφανιστούν σε όλα τα επιλεγμένα αντικείμενα. Αν τελικά θελήσουμε να απελευθερώσουμε μερικά, αρκεί να κάνουμε κλικ επάνω τους, έχοντας πατημένο το Shift. 
Τα επιλεγμένα αντικείμενα συμπεριφέρονται σαν ένα ενιαίο σχήμα. Μετακινώντας ένα, μετακινούνται όλα, ενώ αν διαγράψουμε ένα, θα εξαφανιστούν όλα τα επιλεγμένα από το φύλλο.
Η αλλαγή του μεγέθους ενός από τα επιλεγμένα αντικείμενα, παραμένει ξεχωριστή του ιδιότητα και δεν επηρεάζει τα υπόλοιπα επιλεγμένα.

Η πολλαπλή επιλογή είναι χρήσιμη όταν θέλουμε να εκτελέσουμε την ίδια ενέργεια σε περισσότερα από ένα αντικείμενα, ώστε να μην σπαταλήσουμε χρόνο εκτελώντας την σε κάθε ένα ξεχωριστά.

7.2 Λοιπές Δυνατότητες Επιλογής
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	Υπάρχει η δυνατότητα επιλογής όλων των υπαρχόντων αντικειμένων του διαγράμματός μας. Απλά επιλέγουμε Select → All. Αντίστοιχα, για να απελευθερώσουμε όλες τις επιλογές μας επιλέγουμε  Select → None. Μπορούμε επίσης να αντιστρέψουμε την επιλογή μας. Αυτό σημαίνει ότι, ενώ έχουμε κάποια αντικείμενα επιλεγμένα, μπορούμε να τα απελευθερώσουμε και να μετατραπούν σε επιλεγμένα τα υπόλοιπα, όσα δεν ήταν πριν. Αυτό γίνεται επιλέγοντας Select → Invert.


	
	Στο Dia δίνεται η δυνατότητα σύνδεσης μεταξύ αντικειμένων. Μπορούμε για παράδειγμα να συνδέσουμε σε κάθε άκρη μίας γραμμής ένα ορθογώνιο. Η σύνδεση αυτή γίνεται εφικτή μόνο επάνω σε ένα από τα πράσινα κουτάκια της περιμέτρου και όταν πραγματοποιηθεί, το συγκεκριμένο κουτάκι χρωματίζεται κόκκινο. Στην περίπτωση που κάποια από τα αντικείμενα είναι συνδεδεμένα με το επιλεγμένο και θέλουμε να διευρύνουμε και σε αυτά την επιλογή, επιλέγουμε Select → Connected.


	
	Η παραπάνω περίπτωση αφορά μόνο σε όσα αντικείμενα είναι άμεσα συνδεδεμένα με το αρχικά επιλεγμένο. Υπάρχουν περιπτώσεις που η διασύνδεση εκτείνεται σε αρκετά αντικείμενα, συνδεδεμένα διαδοχικά μεταξύ τους (π.χ. Διαγράμματα ροής, UML, κλπ). Για να επιλεχθούν όλα τα αντικείμενα που βρίσκονται σε άμεση ή μεταβατική σχέση με το αρχικά επιλεγμένο, επιλέγουμε Select → Transitive.

	
	Τέλος, με την επιλογή Select → Same Type, επιλέγονται όλα τα αντικείμενα ιδίου τύπου με το αρχικά επιλεγμένο (π.χ. όλες οι γραμμές, τα παραλληλόγραμμα κ.ο.κ.).


	
	Επίσης υπάρχουν και οι εξής δυνατότητες λειτουργίας της επιλογής στο μενού Select :

1. Replace : Μία νέα επιλογή αναιρεί την προηγούμενη
2. Union : Μία νέα επιλογή προστίθεται στην προηγούμενη. Έτσι η τωρινή επιλογή αποτελεί από τα αντικείμενα και των δύο κ.ο.κ. 
3. Intersect : Όσα αντικείμενα ήταν και στην προηγούμενη και στη νέα επιλογή, αυτά παραμένουν επιλεγμένα
4. Remove : Αφαίρεση από την προηγούμενη επιλογή των αντικειμένων που βρίσκονται και στην νέα επιλογή
5. Invert : Όσα αντικείμενα βρίσκονται στη νέα επιλογή, αντιστρέφεται η κατάστασή τους. Αν ήταν επιλεγμένα παύουν να είναι, ενώ αν δεν ήταν, τώρα είναι.



8. ΦΟΡΤΩΣΗ ΚΑΙ ΑΠΟΘΗΚΕΥΣΗ ΔΙΑΓΡΑΜΜΑΤΩΝ

Το Dia παρέχει τη δυνατότητα αποθήκευσης εργασιών και φόρτωσης υποστηριζόμενου τύπου  αρχείων, όπως όλα τα σύγχρονα προγράμματα. Η αποθήκευση γίνεται μέσω του αναδυόμενου μενού του παραθύρου σχεδίασης, File → Save As. Το αρχείο θα αποθηκευτεί σε Dia XML μορφή. Επειδή δεν προστίθενται αυτόματα επεκτάσεις στα αρχεία, καλό είναι να προσθέτει ο χρήστης την επέκταση “.dia” μετά το όνομα του αρχείου.
Η φόρτωση γίνεται και από το παράθυρο σχεδίασης και από το παράθυρο εργαλείων από την αντίστοιχη επιλογή File → Open. 
Και στις δύο περιπτώσεις, το παράθυρο με τις επιλογές αποθήκευσης ή φόρτωσης που εμφανίζεται έχει την συνηθισμένη μορφή που έχουν όλα τα σημερινά προγράμματα. Η μόνη διαφορά είναι ότι όταν αποθηκεύεται μία εργασία μας, θα είναι υποχρεωτικά Dia XML αρχείο, αφού δεν έχουμε δικαίωμα επιλογής τύπου αρχείου.
8.1
Τύποι Υποστηριζόμενων Αρχείων
· Έμφυτος Τύπος (Dia XML) : Ο μόνος διαθέσιμος τύπος αποθήκευσης. Τα αρχεία αυτού του τύπου είναι από μόνα τους συμπιεσμένα, οπότε αφενός δεν χρειάζεται αφετέρου είναι μη εφικτή περαιτέρω συμπίεση.
· Εισαγόμενοι Τύποι : SVG, DXF, XFig, Bitmaps (*.bmp, *.gif, *.jpg, *.png, *.pnm, *.ras, *.tif).
· Εξαγόμενοι Τύποι : DIA, CGM, dia shape file, DXF, EPS, EPSI, HPGL, PLT, 
PNG, SVG, MP, TEX, WPG, XFig, XSLT.
Για την εξαγωγή ενός διαγράμματος σε μία από τις παραπάνω μορφές, επιλέγουμε από το μενού του παραθύρου σχεδίασης File → Export και επιλέγουμε όνομα και τύπο διαμόρφωσης του αρχείου (Export Options). Με το που θα επιλέξουμε τύπο μετατροπής του αρχείου μας, αυτομάτως θα αλλάξει και η επέκταση του ονόματός του. 
Το Dia αδυνατεί να φορτώσει τους περισσότερους από τους εξαγόμενους τύπους αρχείων. Η δυνατότητα εξαγωγής των διαγραμμάτων μας σε τέτοια μορφή, έχει σαν σκοπό τη χρησιμοποίησή τους σε  εφαρμογές λειτουργικών συστημάτων που δεν υποστηρίζουν το Dia.
9. ΤΡΟΠΟΠΟΙΗΣΗ ΠΕΡΙΒΑΛΛΟΝΤΟΣ ΕΡΓΑΣΙΑΣ


Το Dia προσφέρει κάποιες δυνατότητες τροποποίησης του περιβάλλοντος εργασίας του, σύμφωνα με τις ανάγκες του εκάστοτε χρήστη. Για τη ρύθμιση αυτών των τροποποιήσεων επιλέγουμε στο παράθυρο εργαλείων File → Preferences και εμφανίζονται οι διαθέσιμες επιλογές. Ορισμένες από τις πιο σημαντικές είναι οι παρακάτω :
9.1   User Interface
· Reset tools after create : Αν δεν είναι επιλεγμένο, τότε αν επιλέξουμε ένα αντικείμενο για τοποθέτηση στο φύλλο σχεδίασης, μέχρι να επιλέξουμε ένα άλλο, όποτε θα κάνουμε κλικ πάνω στο φύλλο, θα εισάγεται ένα ακόμη τέτοιο αντικείμενο.  
· Compress saved files : Συμπίεση αρχείων κατά την αποθήκευση
· Number of undo levels : Πλήθος πρόσφατων ενεργειών για αναίρεση
· Use menu bar : Εμφάνιση μπάρας επιλογών στο πάνω μέρος του παραθύρου σχεδίασης
· Reverse dragging selects intersecting objects : Επιτρέπει και την επιλογή αντικειμένων σύροντας το ποντίκι (dragging), από τα δεξιά προς τα αριστερά και με αποδοχή ακόμα και αυτών των αντικειμένων τα οποία δεν είναι ολόκληρα εντός της επιλεγμένης περιοχής, αλλά μόνο ένα μέρος τους.

9.2   Diagram Defaults
· New Diagram : Επιλογή μεγέθους σελίδας και φόντου 

· New Window : Επιλογή μεγέθους παραθύρου σχεδίασης κατά το άνοιγμα (Μήκος, Πλάτος, Μεγέθυνση σελίδων)
9.3 View Defaults 
· Page Breaks : Επιλογές εμφάνισης ορίων μεταξύ σελίδων στο φύλλο σχεδίασης

9.4   Grid Lines
· Visible : Ορατός Τετραγωνισμός
· Snap to : Αγκίστρωση αντικειμένων στις ευθείες του τετραγωνισμού

· Dynamic grid resizing : Αυτόματος τετραγωνισμός. Αν δεν το επιλέξουμε, τότε μπορούμε να ορίσουμε εμείς το σχήμα και τις διαστάσεις του τετραγωνισμού (Μήκος, Πλάτος, Συχνότητα μεγάλων γραμμών)
· Color : Χρώμα γραμμών τετραγωνισμού
Αφού ολοκληρώσουμε τις τροποποιήσεις μας, πατώντας το κουμπί Apply μπορούμε να δούμε τα αποτελέσματα των επιλογών μας. Για να εφαρμοστούν πατάμε ΟΚ, ενώ για ακύρωση πατάμε Close.
10. ΔΙΑΧΕΙΡΙΣΗ ΣΤΡΩΜΑΤΩΝ (LAYERS)

Τα στρώματα λειτουργούν σαν ένα είδος συντόμευσης, για την ομαδοποίηση συσχετισμένων αντικειμένων μέσα σε ένα διάγραμμα. Επιτρέπουν την απομόνωση διαφορετικών τμημάτων ενός διαγράμματος, έτσι ώστε να εμφανίζονται μόνο τα, κατά περίσταση, επιθυμητά τμήματα, ενώ τα υπόλοιπα να μην είναι ορατά, ακόμη και αν γίνει εξαγωγή ή εκτύπωση του διαγράμματος. Μέσα σε ένα στρώμα, η επεξεργασία των αντικειμένων είναι εφικτή μέσω του αναδυόμενου μενού. Τονίζεται ότι κατά την επεξεργασία ενός στρώματος, μόνο τα δικά  του αντικείμενα είναι διαθέσιμα προς επιλογή και κανένα άλλο. Αν λοιπόν είναι αδίαντο να επιλεχθεί ένα αντικείμενο, αυτό σημαίνει ότι δεν είναι μέρος αυτού του στρώματος.

Εξ ορισμού, κάθε νέο διάγραμμα περιέχει ένα στρώμα, το φόντο (Background). To όνομα και οι ιδιότητές του μπορούν να τροποποιηθούν, ανάλογα με τις απαιτήσεις του χρήστη, όπως και κάθε νέο στρώμα. 

Δεν υπάρχει περιορισμός στον αριθμό των στρωμάτων που μπορούν να δημιουργηθούν. Κάθε ένα στρώμα που δημιουργείται, τοποθετείται επάνω στα προηγούμενα, σαν μια στοίβα. Αργότερα δεν μας εμποδίζει κανένας από το να αλλάξουμε  τη σειρά στοίβαξής τους, σύμφωνα με τις ανάγκες τη εργασίας μας.

10.1
Παράθυρο Επιλογών Στρωμάτων

Για να ξεκινήσουμε μία διεργασία με στρώματα, επιλέγουμε από το αναδυόμενο μενού του παραθύρου σχεδίασης  Dialogs → Layers. Εμφανίζεται ένα παράθυρο το οποίο έχει τις ακόλουθες επιλογές :
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	Την επιλογή του διαγράμματος, στο οποίο θα επεξεργαστούμε στρώματα. Επιλογή μπορεί να γίνει μόνο μεταξύ διαγραμμάτων τα οποία είναι ανοιχτά προς επεξεργασία εκείνη τη στιγμή, όχι και αυτών που είναι αποθηκευμένα.
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	Στο μέσον του παραθύρου υπάρχει η λίστα με τα υπάρχοντα στρώματα του επιλεγμένου διαγράμματος. 



	[image: image13.png]afal~]x]





	Κάτω από τη λίστα υπάρχουν τέσσερα κουμπιά. Το πρώτο αριστερά είναι για δημιουργία νέου στρώματος, το επόμενο είναι για άνοδο του στρώματος στη στοίβα, το επόμενο για κάθοδο του στρώματος και το τελευταίο είναι για διαγραφή του επιλεγμένου στρώματος.
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	Τέλος υπάρχει και το κουμπί Close, με το οποίο κλείνουμε το παραπάνω παράθυρο.




10.2
Διεργασίες Με Στρώματα

· Δημιουργία νέου Στρώματος : 

Επιλέγουμε το διάγραμμα όπου θα τοποθετηθεί το νέο στρώμα και πατάμε το κουμπί της δημιουργίας νέου στρώματος. Θα εμφανιστεί στη λίστα των στρωμάτων ένα νέο όνομα «New Layer». Κάνοντας διπλό κλικ επάνω του μας δίνεται η επιλογή αλλαγής του ονόματός του. Το νέο στρώμα τοποθετείται επάνω από τα προηγούμενα και είναι το επιλεγμένο για προσθήκη και επεξεργασία αντικειμένων.

· Επιλογή Στρωμάτων :
Επιλέγουμε ένα στρώμα, από τα υπάρχοντα, κάνοντας κλικ στο όνομά του στη λίστα των στρωμάτων. Τότε είναι δυνατή η επεξεργασία των αντικειμένων αυτού του στρώματος.
· Στοίβαξη Στρωμάτων :

Επιλέγουμε το στρώμα του οποίου τη θέση στη στοίβα θέλουμε να αλλάξουμε, κάνοντας κλικ στο όνομά του στη λίστα των στρωμάτων. Με τα κουμπιά της ανόδου και καθόδου του στρώματος στη στοίβα, το τοποθετούμε στην επιθυμητή θέση. Αυτομάτως όλα τα αντικείμενα αυτού του στρώματος αλλάζουνε επίπεδο στο διάγραμμα.

· Διαγραφή Στρωμάτων :

Επιλέγουμε το στρώμα το οποίο θέλουμε να διαγράψουμε, κάνοντας κλικ στο όνομά του στη λίστα των στρωμάτων. Κατόπιν πατάμε το κουμπί της διαγραφής στρώματος. Αυτομάτως όλα τα αντικείμενα αυτού του στρώματος εξαφανίζονται από το διάγραμμά μας. 

· Ορατό / Μη Ορατό Στρώμα : 
Όλα τα νεοδημιουργηθέντα στρώματα είναι ορατά. Αυτό το καταλαβαίνουμε από το ματάκι που βρίσκεται δίπλα στο όνομα του στρώματος, στη λίστα των στρωμάτων ενός διαγράμματος.
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 Αν κάνουμε κλικ επάνω στο ματάκι, τότε αυτό εξαφανίζεται, δηλαδή το συγκεκριμένο στρώμα καθίσταται αόρατο, άρα όλα τα αντικείμενα που βρίσκονται σε αυτό εξαφανίζονται από το διάγραμμα. Αν ξανακάνουμε κλικ δίπλα στο όνομα του στρώματος το ματάκι θα επανεμφανιστεί και τα αντικείμενα του στρώματος θα ξαναγίνουν ορατά στο διάγραμμά μας. 

Η χρήση των στρωμάτων και των ιδιοτήτων τους στα διαγράμματά μας είναι πολύ σημαντική, αφού διευκολύνουν τη δουλειά μας απεριόριστα. Μας παρέχουν τη δυνατότητα να εκτυπώνουμε ή να εμφανίζουμε διάφορες εκδοχές των διαγραμμάτων, αλλά και να επεξεργαζόμαστε ξεχωριστά τα διαφορετικά τμήματά τους, χωρίς τον κίνδυνο να μπερδευόμαστε λόγω του μεγάλου πλήθους των αντικειμένων μέσα σε ένα διάγραμμα.
11. ΟΔΗΓΙΕΣ ΕΓΚΑΤΑΣΤΑΣΗΣ

Υπάρχουν δύο τρόποι εγκατάστασης του Dia, αφού εκτός από τις κλασικές εκδόσεις τύπου (“.tar.gz”), κυκλοφορούν ολοκληρωμένες εφαρμογές εγκατάστασης (“.rpm” – αντίστοιχες με τις SetUp των Windows), οι οποίες περιλαμβάνουν όλα τα απαραίτητα στοιχεία για την εγκατάσταση και την εκτέλεση του προγράμματος (πακέτα λογισμικού, βιβλιοθήκες κλπ.).


Προτείνεται η χρησιμοποίηση των ολοκληρωμένων πακέτων .rpm τα οποία μπορείτε να βρείτε εύκολα, μέσω μιας μηχανής αναζήτησης, στο Internet. Μία από τις διευθύνσεις από όπου μπορείτε να κατεβάσετε το Dia είναι η : http//:rpmfind.net. Πληκτρολογήστε στο πεδίο αναζήτησης τη λέξη Dia, και θα εμφανιστούν οι διαθέσιμες εκδόσεις. Διαλέξτε αυτή που ταιριάζει στο περιβάλλον εργασίας σας και στα χαρακτηριστικά του υπολογιστή σας, κατεβάστε  την και εκτελέστε την.

Σε κάθε περίπτωση, αν προτιμάτε την κλασική έκδοση, μπορείτε να την κατεβάσετε στη διεύθυνση  http//:www.gnome.org/projects/dia, στην επιλογή Download. Αφού αποσυμπιέσετε το αρχείο, διαβάστε προσεκτικά το αρχείο κειμένου INSTALL, ώστε να δείτε ποιες εφαρμογές είναι απαραίτητες για το πρόγραμμα, πού μπορείτε να τις βρείτε και με ποια σειρά πρέπει να εγκατασταθούν.
12. ΠΛΗΡΟΦΟΡΙΕΣ ΓΙΑ ΤΟ Dia
· Το Dia γράφτηκε από τον Alexander Larsson και συμπληρώθηκε πρόσφατα από τον James Henstridge. Για περισσότερες πληροφορίες και εγκατάσταση μπορείτε να επισκεφτείτε τον δικτυακό τόπο http//:www.gnome.org/projects/dia , ενώ για αναφορές σφαλμάτων επικοινωνήστε με το http//:bugs.gnome.org.
· Για τη σύνταξη του παρόντος χρησιμοποιήθηκαν τα παρακάτω εγχειρίδια :

1. Dia Manual, written by Kevin Breit, Henry House & Judith Samson

2. Debian GNU/Linux Desktop Survival Guide (Chap. Dia: Charts & Diagrams), written by Graham Williams
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